europa 4 1.28.3 update

Europa Universalis IV – 1.28 Hotfixes, Patch Notes & Updates

With version 1.28 the system requirements have been updated. If you can not meet these updated requirements, then we recommend that you do not buy Golden Century and you should keep your game on version 1.27.2! Minimum requirements 4GB RAM (up from 2GB) 6GB hard drive space (up from 2GB) Recommended requirements 8GB RAM (up from 2GB) 6GB hard drive space (up from 2GB) 1.28.3 Hotfix Patch Notes Gam...

Lost Password

Sign Up